summaryrefslogtreecommitdiffstats
path: root/sesman/chansrv/Makefile.am
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2012-11-02 23:10:36 -0700
committerJay Sorg <jay.sorg@gmail.com>2012-11-02 23:10:36 -0700
commitcdb039080f47ee31e97dcb88591e8194e03f3878 (patch)
treee3a69c2cd301d7b326a3abec7256a8ddc6651be7 /sesman/chansrv/Makefile.am
parent02d52444c3747b5a5066788076d8f9c1e9df2440 (diff)
downloadxrdp-proprietary-cdb039080f47ee31e97dcb88591e8194e03f3878.tar.gz
xrdp-proprietary-cdb039080f47ee31e97dcb88591e8194e03f3878.zip
chansrv: added --enable-fuse option
Diffstat (limited to 'sesman/chansrv/Makefile.am')
-rw-r--r--sesman/chansrv/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/sesman/chansrv/Makefile.am b/sesman/chansrv/Makefile.am
index b6b6de2b..4272eb0e 100644
--- a/sesman/chansrv/Makefile.am
+++ b/sesman/chansrv/Makefile.am
@@ -10,6 +10,11 @@ EXTRA_DEFINES += -DXRDP_SIMPLESOUND
EXTRA_LIBS += -lpthread -lpulse -lpulse-simple
endif
+if XRDP_FUSE
+EXTRA_DEFINES += -DXRDP_FUSE
+EXTRA_LIBS += -lfuse
+endif
+
AM_CFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
@@ -36,7 +41,7 @@ xrdp_chansrv_SOURCES = \
chansrv_fuse.c
xrdp_chansrv_LDFLAGS = \
- $(EXTRA_FLAGS) -lfuse
+ $(EXTRA_FLAGS)
xrdp_chansrv_LDADD = \
-L/usr/X11R6/lib \