summaryrefslogtreecommitdiffstats
path: root/sesman/libscp/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-01-29 22:45:00 -0800
committerPavel Roskin <plroskin@gmail.com>2016-01-29 22:45:00 -0800
commita452d8d36aafda4a873f8c035a3fe3fd51fabd96 (patch)
tree17ce42f7a222d165308585f6d8be3e205a5e95f0 /sesman/libscp/Makefile.am
parent309fca35acfeb776a422d6140ddae8be0b1dbff0 (diff)
downloadxrdp-proprietary-a452d8d36aafda4a873f8c035a3fe3fd51fabd96.tar.gz
xrdp-proprietary-a452d8d36aafda4a873f8c035a3fe3fd51fabd96.zip
Merge AM_CFLAGS and INCLUDES info AM_CPPFLAGS
AM_CPPFLAGS is for flags passed to the preprocessor, such as defines and includes. AM_CFLAGS is for flags affecting the compiler, such as debug and optimization settings. INCLUDES is an obsolete name. Users can pass INCLUDES and break compilation. AM_CPPFLAGS is more explicit that the flags come from Automake and should not be overridden.
Diffstat (limited to 'sesman/libscp/Makefile.am')
-rw-r--r--sesman/libscp/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/sesman/libscp/Makefile.am b/sesman/libscp/Makefile.am
index eaf518a8..3172f2cb 100644
--- a/sesman/libscp/Makefile.am
+++ b/sesman/libscp/Makefile.am
@@ -1,13 +1,11 @@
EXTRA_DIST = libscp_connection.h libscp_commands.h libscp.h libscp_session.h libscp_types_mng.h libscp_v1c_mng.h libscp_vX.h libscp_commands_mng.h libscp_init.h libscp_tcp.h libscp_v0.h libscp_v1s.h libscp_lock.h \
libscp_types.h libscp_v1c.h libscp_v1s_mng.h
-AM_CFLAGS = \
+AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
- -DXRDP_PID_PATH=\"${localstatedir}/run\"
-
-INCLUDES = \
+ -DXRDP_PID_PATH=\"${localstatedir}/run\" \
-I$(top_srcdir)/common
lib_LTLIBRARIES = \