summaryrefslogtreecommitdiffstats
path: root/xrdp/Makefile.am
diff options
context:
space:
mode:
authorJay Sorg <jay.sorg@gmail.com>2016-08-08 20:02:10 -0700
committerJay Sorg <jay.sorg@gmail.com>2016-08-08 20:02:10 -0700
commit58c777783bc19e7288743a49d839b1ed14a9452f (patch)
treee6bf6abdcd6eda7ad4f36dc3236af9f8563325f5 /xrdp/Makefile.am
parent660132a49deb06c55367ea83ce5a4d8459e90d77 (diff)
downloadxrdp-proprietary-58c777783bc19e7288743a49d839b1ed14a9452f.tar.gz
xrdp-proprietary-58c777783bc19e7288743a49d839b1ed14a9452f.zip
add more advances region support using pixman
Diffstat (limited to 'xrdp/Makefile.am')
-rw-r--r--xrdp/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/xrdp/Makefile.am b/xrdp/Makefile.am
index 67ff4df8..4988c1bc 100644
--- a/xrdp/Makefile.am
+++ b/xrdp/Makefile.am
@@ -14,6 +14,12 @@ EXTRA_INCLUDES += -I$(top_srcdir)/librfxcodec/include
EXTRA_LIBS += $(top_srcdir)/librfxcodec/src/librfxencode.a
endif
+if XRDP_PIXMAN
+EXTRA_DEFINES += -DXRDP_PIXMAN
+EXTRA_INCLUDES += $(XRDP_PIXMAN_CFLAGS)
+EXTRA_LIBS += $(XRDP_PIXMAN_LIBS)
+endif
+
AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \