summaryrefslogtreecommitdiffstats
path: root/xrdp/Makefile.am
diff options
context:
space:
mode:
authorPavel Roskin <plroskin@gmail.com>2016-10-17 11:09:50 -0700
committerPavel Roskin <plroskin@gmail.com>2016-10-20 10:43:02 -0700
commita370306f75e72a38f37a0cc7ee1fae595d3c80bc (patch)
treeed0a9eb35e6a1ac50add0b0589111637538b20e8 /xrdp/Makefile.am
parent5c69f3cd57ac9052d4d69e13c751463775f58b6d (diff)
downloadxrdp-proprietary-a370306f75e72a38f37a0cc7ee1fae595d3c80bc.tar.gz
xrdp-proprietary-a370306f75e72a38f37a0cc7ee1fae595d3c80bc.zip
Get rid of EXTRA_LIBS, use variables with more specific names
Diffstat (limited to 'xrdp/Makefile.am')
-rw-r--r--xrdp/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/xrdp/Makefile.am b/xrdp/Makefile.am
index e2266a22..e24f22e2 100644
--- a/xrdp/Makefile.am
+++ b/xrdp/Makefile.am
@@ -1,5 +1,3 @@
-EXTRA_LIBS =
-
AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
@@ -10,6 +8,8 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/common \
-I$(top_srcdir)/libxrdp
+XRDP_EXTRA_LIBS =
+
if XRDP_DEBUG
AM_CPPFLAGS += -DXRDP_DEBUG
else
@@ -19,13 +19,13 @@ endif
if XRDP_RFXCODEC
AM_CPPFLAGS += -DXRDP_RFXCODEC
AM_CPPFLAGS += -I$(top_srcdir)/librfxcodec/include
-EXTRA_LIBS += $(top_srcdir)/librfxcodec/src/.libs/librfxencode.a
+XRDP_EXTRA_LIBS += $(top_srcdir)/librfxcodec/src/.libs/librfxencode.a
endif
if XRDP_PIXMAN
AM_CPPFLAGS += -DXRDP_PIXMAN
AM_CPPFLAGS += $(XRDP_PIXMAN_CFLAGS)
-EXTRA_LIBS += $(XRDP_PIXMAN_LIBS)
+XRDP_EXTRA_LIBS += $(XRDP_PIXMAN_LIBS)
endif
sbin_PROGRAMS = \
@@ -53,7 +53,7 @@ xrdp_SOURCES = \
xrdp_LDADD = \
$(top_builddir)/common/libcommon.la \
$(top_builddir)/libxrdp/libxrdp.la \
- $(EXTRA_LIBS)
+ $(XRDP_EXTRA_LIBS)
xrdpsysconfdir=$(sysconfdir)/xrdp