summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 39 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e8905c98..6d644836 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,27 @@
-EXTRA_DIST = bootstrap COPYING design.txt faq-compile.txt faq-general.txt file-loc.txt install.txt prog_std.txt readme.txt
+ACLOCAL_AMFLAGS = -I m4
+AM_DISTCHECK_CONFIGURE_FLAGS = --without-systemdsystemunitdir
+
+EXTRA_DIST = \
+ COPYING \
+ README.md \
+ NEWS.md \
+ astyle_config.as \
+ bootstrap \
+ coding_style.md \
+ description-pak \
+ design.txt \
+ faq-compile.txt \
+ faq-general.txt \
+ file-loc.txt \
+ fontdump \
+ install.txt \
+ m4 \
+ postinstall-pak \
+ readme.txt \
+ tcutils \
+ tests \
+ vrplayer \
+ xorg
if XRDP_NEUTRINORDP
NEUTRINORDPDIR = neutrinordp
@@ -12,6 +35,18 @@ else
XRDPVRDIR =
endif
+if XRDP_PAINTER
+PAINTERDIR = libpainter
+else
+PAINTERDIR =
+endif
+
+if XRDP_RFXCODEC
+RFXCODECDIR = librfxcodec
+else
+RFXCODECDIR =
+endif
+
SUBDIRS = \
common \
vnc \
@@ -20,6 +55,8 @@ SUBDIRS = \
mc \
$(NEUTRINORDPDIR) \
libxrdp \
+ $(PAINTERDIR) \
+ $(RFXCODECDIR) \
xrdp \
sesman \
keygen \
@@ -27,4 +64,5 @@ SUBDIRS = \
instfiles \
genkeymap \
xrdpapi \
+ pkgconfig \
$(XRDPVRDIR)