summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1a150e8..9730aaad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,10 @@ AC_ARG_ENABLE(rfxcodec, AS_HELP_STRING([--enable-rfxcodec],
[Build using librfxcodec (default: no)]),
[], [enable_rfxcodec=no])
AM_CONDITIONAL(XRDP_RFXCODEC, [test x$enable_rfxcodec = xyes])
+AC_ARG_ENABLE(opus, AS_HELP_STRING([--enable-opus],
+ [Build opus(audio codec) (default: no)]),
+ [], [enable_opus=no])
+AM_CONDITIONAL(XRDP_OPUS, [test x$enable_opus = xyes])
AM_CONDITIONAL(GOT_PREFIX, test "x${prefix}" != "xNONE"])
@@ -122,6 +126,13 @@ then
[#define _FILE_OFFSET_BITS 64])
fi
+# checking for opus
+if test "x$enable_opus" = "xyes"
+then
+ AC_CHECK_HEADER([opus/opus.h], [],
+ [AC_MSG_ERROR([please install libopus-dev or opus-devel])])
+fi
+
# checking for TurboJPEG
if test "x$enable_tjpeg" = "xyes"
then