summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/readme.txt3
-rw-r--r--debian/rules10
2 files changed, 7 insertions, 6 deletions
diff --git a/debian/readme.txt b/debian/readme.txt
index 48cc9207..867843c7 100644
--- a/debian/readme.txt
+++ b/debian/readme.txt
@@ -2,6 +2,7 @@ This is the debian directory used to make a .deb file to install
xrdp. It installs to /usr/lib/xrdp.
To make a new deb type
-dpkg --build
+remember, debian/rules must be executable
+fakeroot dpkg-buildpackage -b -uc -us -d
Jay
diff --git a/debian/rules b/debian/rules
index 3f1e32a3..48ff9b6e 100644
--- a/debian/rules
+++ b/debian/rules
@@ -30,7 +30,7 @@ configure-stamp:
build: build-stamp
-build-stamp: configure-stamp
+build-stamp: configure-stamp
dh_testdir
# Add here commands to compile the package.
@@ -47,12 +47,12 @@ clean:
# Add here commands to clean up after the build process.
-$(MAKE) clean
- dh_clean
+ dh_clean
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_clean -k
dh_installdirs
# Add here commands to install the package into debian/xrdp.
@@ -67,12 +67,12 @@ binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
- dh_installchangelogs
+ dh_installchangelogs
dh_installdocs
dh_installexamples
# dh_install
# dh_installmenu
-# dh_installdebconf
+# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam