summaryrefslogtreecommitdiffstats
path: root/freerdp1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'freerdp1/Makefile.am')
-rw-r--r--freerdp1/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/freerdp1/Makefile.am b/freerdp1/Makefile.am
new file mode 100644
index 00000000..a15fb633
--- /dev/null
+++ b/freerdp1/Makefile.am
@@ -0,0 +1,20 @@
+EXTRA_DIST = xrdp-freerdp.h
+
+AM_CFLAGS = \
+ -DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
+ -DXRDP_SBIN_PATH=\"${sbindir}\" \
+ -DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
+ -DXRDP_PID_PATH=\"${localstatedir}/run\"
+
+INCLUDES = \
+ -I$(top_srcdir)/common \
+ $(FREERDP_CFLAGS)
+
+lib_LTLIBRARIES = \
+ libxrdpfreerdp1.la
+
+libxrdpfreerdp1_la_SOURCES = xrdp-freerdp.c
+
+libxrdpfreerdp1_la_LIBADD = \
+ $(top_srcdir)/common/libcommon.la \
+ $(FREERDP_LIBS)