summaryrefslogtreecommitdiffstats
path: root/rdp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rdp/Makefile.am')
-rw-r--r--rdp/Makefile.am23
1 files changed, 9 insertions, 14 deletions
diff --git a/rdp/Makefile.am b/rdp/Makefile.am
index 9b519d7c..30368156 100644
--- a/rdp/Makefile.am
+++ b/rdp/Makefile.am
@@ -1,27 +1,22 @@
-EXTRA_DIST = rdp.h
-EXTRA_DEFINES =
-
-if XRDP_DEBUG
-EXTRA_DEFINES += -DXRDP_DEBUG
-else
-EXTRA_DEFINES += -DXRDP_NODEBUG
-endif
-
-AM_CFLAGS = \
+AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
-DXRDP_PID_PATH=\"${localstatedir}/run\" \
- $(EXTRA_DEFINES)
-
-INCLUDES = \
-I$(top_srcdir)/common
-lib_LTLIBRARIES = \
+if XRDP_DEBUG
+AM_CPPFLAGS += -DXRDP_DEBUG
+else
+AM_CPPFLAGS += -DXRDP_NODEBUG
+endif
+
+module_LTLIBRARIES = \
librdp.la
librdp_la_SOURCES = \
rdp.c \
+ rdp.h \
rdp_bitmap.c \
rdp_iso.c \
rdp_lic.c \