summaryrefslogtreecommitdiffstats
path: root/sesman/chansrv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sesman/chansrv/Makefile.am')
-rw-r--r--sesman/chansrv/Makefile.am88
1 files changed, 50 insertions, 38 deletions
diff --git a/sesman/chansrv/Makefile.am b/sesman/chansrv/Makefile.am
index 7a97c136..7a2672a8 100644
--- a/sesman/chansrv/Makefile.am
+++ b/sesman/chansrv/Makefile.am
@@ -1,62 +1,74 @@
EXTRA_DIST = \
- chansrv.h \
- chansrv_fuse.h \
- clipboard.h \
- clipboard_common.h \
- clipboard_file.h \
- devredir.h \
- drdynvc.h \
- rail.h \
- sound.h \
- xcommon.h \
- mlog.h \
- chansrv_common.h
-
-EXTRA_DEFINES =
-EXTRA_INCLUDES =
-EXTRA_LIBS =
-EXTRA_FLAGS =
+ clipboard-notes.txt \
+ pcsc \
+ pulse \
+ wave-format-server.txt
-if XRDP_FUSE
-EXTRA_DEFINES += -DXRDP_FUSE
-EXTRA_LIBS += -lfuse
-endif
-
-AM_CFLAGS = \
+AM_CPPFLAGS = \
-DXRDP_CFG_PATH=\"${sysconfdir}/xrdp\" \
-DXRDP_SBIN_PATH=\"${sbindir}\" \
-DXRDP_SHARE_PATH=\"${datadir}/xrdp\" \
-DXRDP_PID_PATH=\"${localstatedir}/run\" \
- $(EXTRA_DEFINES)
+ -I$(top_srcdir)/common
+
+CHANSRV_EXTRA_LIBS =
+
+if XRDP_FUSE
+AM_CPPFLAGS += -DXRDP_FUSE $(FUSE_CFLAGS)
+CHANSRV_EXTRA_LIBS += $(FUSE_LIBS)
+endif
+
+if XRDP_OPUS
+AM_CPPFLAGS += -DXRDP_OPUS
+CHANSRV_EXTRA_LIBS += -lopus
+endif
+
+if XRDP_MP3LAME
+AM_CPPFLAGS += -DXRDP_MP3LAME
+CHANSRV_EXTRA_LIBS += -lmp3lame
+endif
-INCLUDES = \
- -I$(top_srcdir)/common \
- $(EXTRA_INCLUDES)
+AM_CFLAGS = $(X_CFLAGS)
sbin_PROGRAMS = \
xrdp-chansrv
xrdp_chansrv_SOURCES = \
chansrv.c \
- sound.c \
+ chansrv.h \
+ chansrv_common.c \
+ chansrv_common.h \
+ chansrv_fuse.c \
+ chansrv_fuse.h \
clipboard.c \
+ clipboard.h \
+ clipboard_common.h \
clipboard_file.c \
+ clipboard_file.h \
devredir.c \
+ devredir.h \
+ drdynvc.c \
+ drdynvc.h \
+ fifo.c \
+ fifo.h \
+ irp.c \
+ irp.h \
+ mlog.h \
+ rail.c \
+ rail.h \
smartcard.c \
+ smartcard.h \
smartcard_pcsc.c \
- rail.c \
+ smartcard_pcsc.h \
+ sound.c \
+ sound.h \
xcommon.c \
- drdynvc.c \
- chansrv_fuse.c \
- irp.c \
- fifo.c \
- chansrv_common.c
+ xcommon.h
xrdp_chansrv_LDFLAGS = \
- $(EXTRA_FLAGS)
+ $(X_LIBS)
xrdp_chansrv_LDADD = \
- -L/usr/X11R6/lib \
$(top_builddir)/common/libcommon.la \
- -lX11 -lXfixes -lXrandr \
- $(EXTRA_LIBS)
+ $(X_PRE_LIBS) -lXfixes -lXrandr -lX11 $(X_EXTRA_LIBS) \
+ $(CHANSRV_EXTRA_LIBS)