summaryrefslogtreecommitdiffstats
path: root/lib/kross/python/cxx/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /lib/kross/python/cxx/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'lib/kross/python/cxx/Makefile.am')
-rw-r--r--lib/kross/python/cxx/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/lib/kross/python/cxx/Makefile.am b/lib/kross/python/cxx/Makefile.am
new file mode 100644
index 00000000..d1c72c87
--- /dev/null
+++ b/lib/kross/python/cxx/Makefile.am
@@ -0,0 +1,19 @@
+include $(top_srcdir)/lib/kross/Makefile.global
+
+noinst_LTLIBRARIES = libkrosspythoncxx.la
+
+libkrosspythoncxx_la_SOURCES = \
+ cxxsupport.cxx \
+ cxx_extensions.cxx \
+ cxxextensions.c \
+ IndirectPythonInterface.cxx
+
+libkrosspythoncxx_la_LDFLAGS = $(LIBPYTHON) $(all_libraries) -Wnounresolved
+
+METASOURCES = AUTO
+INCLUDES = $(KROSS_INCLUDES) $(PYTHONINC) $(all_includes)
+SUBDIRS = .
+
+clean:
+ @rm -f *.o 2> /dev/null
+ @rm -f $(BIN) 2> /dev/null