summaryrefslogtreecommitdiffstats
path: root/lib/kross/python/cxx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kross/python/cxx/Makefile.am')
-rw-r--r--lib/kross/python/cxx/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/lib/kross/python/cxx/Makefile.am b/lib/kross/python/cxx/Makefile.am
new file mode 100644
index 00000000..d1c72c87
--- /dev/null
+++ b/lib/kross/python/cxx/Makefile.am
@@ -0,0 +1,19 @@
+include $(top_srcdir)/lib/kross/Makefile.global
+
+noinst_LTLIBRARIES = libkrosspythoncxx.la
+
+libkrosspythoncxx_la_SOURCES = \
+ cxxsupport.cxx \
+ cxx_extensions.cxx \
+ cxxextensions.c \
+ IndirectPythonInterface.cxx
+
+libkrosspythoncxx_la_LDFLAGS = $(LIBPYTHON) $(all_libraries) -Wnounresolved
+
+METASOURCES = AUTO
+INCLUDES = $(KROSS_INCLUDES) $(PYTHONINC) $(all_includes)
+SUBDIRS = .
+
+clean:
+ @rm -f *.o 2> /dev/null
+ @rm -f $(BIN) 2> /dev/null